Ubuntu 14.04 – No USB keyboard after upgrading kernel

After upgrading my Ubuntu 14.04 LTS install from linux kernel 3.13 to 3.16, USB input devices, particularly my keyboard, stopped working.

On rebooting to an older kernel, the keyboard worked again. The reason for this, is that the base kernel package doesn’t include the usbhid module, which is require for USB input devices.

The solution, is to install the linux-image-extra package for your kernel. In my case it was:

sudo apt-get install linux-image-extra-3.16.0-28-generic

You can either do this via ssh, or boot to an older working kernel first.

Afterwards, you should be able to do modprobe usbhid, or simply reboot, and your usb input devices should function correctly.

12 thoughts on “Ubuntu 14.04 – No USB keyboard after upgrading kernel

  1. Badari Narayana

    Hi Alex, Thanks for this article. It solved my bugging problem that after reboot of Ubuntu 14.04.2 LTS, the USB based Key Board and Serial interface stopped working. I had tried several suggestions from the internet, but none of them worked. Many thanks for this information.

    Reply
  2. Chris

    Thanks a lot for this post. It worked perfectly.
    For me it looked very strange, as GRUB menu was still working – and at the moment ubuntu took over – there was no keyboard anymore.

    Reply
    1. Alex Forbes Post author

      Glad it worked!

      Your keyboard worked in Grub because the Linux kernel hasn’t been loaded at that stage; Grub has its own basic set of drivers and has to operate independently of the Linux kernel. Thus, a missing driver in Linux doesn’t affect it. :)

      Reply
  3. hipitihop

    Thanks so much for taking the time to post this solution. I had been battling with this for weeks. I found 3.16.0-031600.2014 worked fine and a soon as I tried to upgrade anything between 3.16.0-62 – 4.2.0-30.34~14.04.1 , no keyboard or mouse in the login screen. Problem solved. Many thanks.

    Reply
  4. Clement

    Hi, thanks very much for your sharing via post! I am a person from Hong Kong. Getting to your post via Googling “ubuntu 3.13.0.95 keyboard unresponsive”.

    I have been battling with this issue after the Ubuntu 14.04.05 LTS (trusty) has been recently updated via “Software Updater” which I think the kernel has been upgraded from “3.13.0-91-generic” to “3.13.0-95-generic” (as shown in the GRUB bootloader “Advanced options for Ubuntu”).

    By the way, I love New Zealand, especially the spectacular natural scenes and I love playing paragliding very much!

    Reply
    1. Alex Forbes Post author

      Hi Clement, thanks for commenting. I have never been to Hong Kong but hope to visit some day, the politics in particular fascinates me. Anyway, hope it helped you resolve your issue!

      Reply
      1. Clement

        Yes Alex, the problem get solved! Your generous sharing saved my life!

        Whenever you come to Hong Kong, feel free to call me for hangout!

        Reply

Leave a Reply